Data refresh issue in Visual Insights and Data Explorer

Incident Report for Lever

Resolved

The data refresh issue in Visual Insights and Data explorer has been resolved. There should be no further impact at this time, but please reach out to us at Support if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new
Posted Jul 15, 2025 - 23:09 PDT

Identified

We’ve identified the issue causing degraded data syncing to Visual Insights, we have implemented a fix, and are working to establish faster data syncing. Additional updates will be provided as soon as possible
Posted Jul 15, 2025 - 10:34 PDT
This incident affected: Global Data Center - LeverTRM (Visual Insights) and EU Data Center - LeverTRM (Visual Insights).