Stale Visual Insights Data

Incident Report for Lever

Postmortem

Incident Summary

Between June 14 and June 18, 2026, analytics reports in the Visual Insights "Custom Data Explorer" displayed outdated information. While the live platform remained fully accurate and no data was lost, the reports stopped reflecting real-time changes (such as candidate stage updates). This resulted in a "stale" snapshot of data being shown to all reporting customers for approximately four days.

Detection

The issue was identified on June 17, 2026, following reports from customers who noticed that their report counts did not match the live data in the platform. Upon investigation, our engineering team confirmed that the data pipeline responsible for updating these reports had stopped processing new information on June 14.

Resolution

Once identified, our engineering team restarted the affected component, which safely resumed and caught up on all pending changes with no data loss. Report accuracy was fully restored, and the cited figures now match the live platform. No action was required from customers at any point.

Preventative Measures

To prevent this issue from recurring, we have taken the following actions:

  • Enhanced Auto-Recovery: We updated the system to automatically recognize and recover from this specific type of database restart error, allowing it to self-heal without manual intervention.
  • Improved Monitoring: We are implementing more granular alerts that monitor the specific workers within the data pipeline. This ensures that if a single worker stops, we are notified within minutes.
  • Data Freshness Checks: We are adding new automated checks that compare live platform data against the reporting store to detect any "freshness" gaps immediately.
Posted Jun 22, 2026 - 12:50 PDT

Resolved

The data backfill has completed at approximately 5:00am PST/PDT on 6/18/2026.

All Visual Insights reports should now be a complete and accurate representation of current data.

A root cause analysis (RCA) will be published to this incident within the standard Service Level Agreement (SLA).
Posted Jun 18, 2026 - 05:00 PDT

Monitoring

We are continuing to monitor the effectiveness of the fix for Visual Insights reporting. We anticipate that reporting data may still have discrepancies for approximately 10 to 15 hours. We are continuing to monitor that data is backfilling on schedule as expected.

Next update: 6/17/2026 5pm PST/PDT or sooner.
Posted Jun 17, 2026 - 11:33 PDT

Identified

We have identified the issue affecting the Visual Insights (Snowflake) database and have implemented a fix on Wednesday, June 17 at approximately 10:30am PST/PDT.
Posted Jun 17, 2026 - 10:30 PDT

Update

We are continuing to investigate this issue affecting Visual Insights.

New data may be delayed to appear in Visual Insights or may be missing.

Start time: 6/16/2026 7:30am PST/PDT
Next update: 6/17/2026 8am PST/PDT or sooner.
Posted Jun 16, 2026 - 15:33 PDT

Investigating

We became aware of an issue affecting the North America data center where Visual Insights is not loading new data in some customer accounts. The issue started occurring on Tuesday, 6/16/2026 at approximately 7:30am PST/PDT.

Updates will be provided as we work to investigate the issue.
Posted Jun 16, 2026 - 10:30 PDT
This incident affected: Global Data Center - LeverTRM (Visual Insights).