O365 Email Integration is Down
Incident Report for Lever
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 25, 2019 - 21:48 PDT
Identified
This issue has been identified as a bug with an API endpoint. We are currently working with Microsoft to identify a fix.
Posted 6 months ago. Apr 25, 2019 - 16:48 PDT
Investigating
We are currently investigating this issue.
Posted 6 months ago. Apr 25, 2019 - 15:34 PDT
This incident affected: hire.