Intermittent issues impacting Lever Hire's email/calendar integration

Incident Report for Lever

Resolved

The issue with the email/calendar integration checkboxes has been resolved. There should be no further impact at this time, but please reach out to us at Support if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new
Posted Jun 18, 2025 - 11:04 PDT

Monitoring

A fix has been implemented for the issue affecting the email/calendar integration permissions. Customers should now be able to / see the email/calendar checkbox options present in their settings once more. We’re currently monitoring to ensure that there are no further issues, and we’ll send a final update to confirm that there have been no recurrences.
Posted Jun 18, 2025 - 09:58 PDT

Investigating

We are currently investigating an issue that is intermittently affecting the email/calendar integration permissions. Issues impacting the email/calendar integration were noticed around 5:30 AM PST on 6/18/2025. Users may intermittently experience issues with granting permissions to email and contacts. Our Engineering teams are actively working to resolve this as soon as possible.
Posted Jun 18, 2025 - 09:39 PDT
This incident affected: EU Data Center - LeverTRM (Hire) and Global Data Center - LeverTRM (Hire).