Delay in processing candidates to HireRight
Incident Report for Lever
Resolved
This incident has been resolved.
Posted Apr 02, 2020 - 10:33 PDT
Investigating
We are currently experiencing issues with a delay in pushing candidates to HireRight for background checks. We are investigating the issue and will provide updates as they are available.
Posted Mar 27, 2020 - 12:09 PDT
This incident affected: EU Data Center - LeverTRM (Hire).