Offers stuck in "Sending" state
Incident Report for Lever
Resolved
The issue with Offers stuck in a "Sending" status is now resolved. You can now continue to send Offers without issue.
Posted about 2 months ago. Jul 02, 2019 - 16:40 PDT
Investigating
We are currently investigating an issue that is causing Offers to become stuck in "Sending" status. We will continue to make updates as progress is made.
Posted about 2 months ago. Jul 02, 2019 - 16:03 PDT
This incident affected: hire.