Interviewers who are using Microsoft Exchange are not receiving calendar notification for their interviews
Incident Report for Lever
Resolved
The issue where calendar notifications were not being sent to interviewers affecting customers Microsoft Exchange users has been resolved. The incident occurred from Monday, July 27th. There should be no further impact at this time, but please reach out to us at Support if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new
Posted Aug 13, 2020 - 14:47 PDT
Investigating
We are currently investigating an issue where interviewers are not receiving calendar notifications when interviews are scheduled, affecting customers that are on Microsoft Exchange. Our 3rd party intermediary is investigating this behavior. We became aware of this issue on Monday, July 27th, and affected users will see interviews scheduled within Lever but not on the interviewer's email calendar. We will keep you updated as we continue monitoring this issue and await further information from our partner team.
Posted Jul 30, 2020 - 10:25 PDT
This incident affected: interviewer.