Slowness on Lever Hire
Incident Report for Lever
Resolved
The issue where users we're experiencing slowness in Lever has been resolved. Users should no longer see any error messages when logging into Lever and there should be no further impact at this time, but please reach out to us at Support if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new
Posted Jan 23, 2024 - 09:58 PST
Monitoring
A fix has been implemented for the issue causing slowness in Lever. Customers should now be able to utilize Lever without any issues moving forward. We’re currently monitoring to ensure that there are no further issues, and we’ll send a final update to confirm that there have been no recurrences.
Posted Jan 23, 2024 - 08:40 PST
Investigating
We are currently investigating an issue causing slowness in Lever Hire. Issues impacting Lever Hire were noticed around 7:45am PST. Users may intermittently experience slowness or not able to utilize Lever. Our Engineering teams are actively working to resolve this as soon as possible.
Posted Jan 23, 2024 - 07:56 PST
This incident affected: Global Data Center - LeverTRM (Hire).