Delayed inbox notifications
Incident Report for Lever
Resolved
This incident has been resolved.
Posted 6 months ago. May 03, 2019 - 14:39 PDT
Investigating
We're currently investigating an issue impacting inbox notifications. Users may also see a delay in email notifications and interview RSVP updates.
Posted 6 months ago. May 03, 2019 - 13:44 PDT
This incident affected: hire.