Degraded Services - scheduling and interview panel updates
Incident Report for Lever
Resolved
This incident has been resolved and Gsuite users can resume scheduling interviews.
Posted Jun 22, 2020 - 16:56 PDT
Monitoring
We are monitoring this issue where Gsuite users were not able to schedule an interview.
Posted Jun 22, 2020 - 16:41 PDT
Investigating
We are experiencing an issue that is causing degraded performance for interview scheduling, interview panel updates, and viewing calendar availability for GSuite users.
Posted Jun 22, 2020 - 16:06 PDT
This incident affected: EU Data Center - LeverTRM (Hire).