Delays in Lever
Incident Report for Lever
Resolved
Mailgun has confirmed that the issue with delays is resolved. More information on the incident can be found here https://status.mailgun.com/.
Posted Mar 06, 2023 - 10:05 PST
Monitoring
We have identified an issue with a third party, Mailgun, which is creating delays for actions taken in Lever. Mailgun is investigating, and you can see additional updates here https://status.mailgun.com/. We became aware of this issue at 11:55 am PST, and affected users will see/experience delayed email sending, automations and applications. We will keep you updated as we continue monitoring this issue and await further information from Mailgun.
Posted Feb 21, 2023 - 12:18 PST
This incident affected: EU Data Center - LeverTRM (Hire) and Global Data Center - LeverTRM (Hire).