Candidate Email address update issue
Incident Report for Lever
Resolved
The issue where emails were not updating properly that was affecting customers with the Winter 2024 release has been resolved. The incident occurred from Winter '24 release date to Feb 15 8:15am PST. There should be no further impact at this time, but please reach out to us at Support if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new
Posted Feb 15, 2024 - 08:42 PST
Identified
We’ve identified the issue causing candidate email addresses to not update, and we’re working to implement a fix. Additional updates will be provided as soon as a resolution is in place.
Posted Feb 14, 2024 - 15:30 PST
Investigating
We are currently investigating an issue that is intermittently affecting users' ability to update a candidate's email address. Issues impacting accounts with the Winter 2024 release were noticed around Feb 12 at 9am. Users should double check which email address they are sending to when drafting emails. Additionally, scheduling events will go to the candidate's previous email address. Our Engineering teams are actively working to resolve this as soon as possible.
Posted Feb 14, 2024 - 09:21 PST
This incident affected: EU Data Center - LeverTRM (Hire) and Global Data Center - LeverTRM (Hire).