Intermittent Scheduling Errors
Incident Report for Lever
Resolved
Some customers may have experienced trouble using Lever's calendaring functionality today. We have identified and addressed the root cause. If you are still experiencing any issues, please contact us at support@lever.co.
Posted over 1 year ago. Jan 23, 2018 - 16:26 PST
Identified
Some customers may be experiencing trouble connecting to Lever's calendaring functionality (conference room loading, scheduling, etc). We are aware of the issue and are working toward a resolution. We apologize for any inconvenience!
Posted over 1 year ago. Jan 23, 2018 - 15:58 PST