The issue with Mailgun that was affecting using a Lever-created Sub-domain, Lever Mail, and email notifications has been resolved. The incident occurred from “8/14/2024 9:30 AM PDT to 11:45 AM PDT. There should be no further impact at this time, but please reach out to us at Support if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new
Posted Aug 14, 2024 - 11:51 PDT
Identified
We have identified an issue with Mailgun, affecting customers using a Lever-created Sub-domain, Lever Mail, and email notifications. We are working to fix this as soon as possible. We became aware of this issue at 9:30 am PDT, and affected users will see emails from Lever Mail fail to send, may not receive email notifications, and customers using SPF/ICS will temporarily be unable to send emails or schedule interviews. We will keep you updated as we continue monitoring this issue and await further information.
Posted Aug 14, 2024 - 10:19 PDT
This incident affected: EU Data Center - LeverTRM (Hire) and Global Data Center - LeverTRM (Hire).