Intermittent issues impacting Lever Hire - Unable to Search
Incident Report for Lever
Postmortem

Starting on June 10 at 12:30 PM ET users began experiencing intermittent issues with users not being able to search. This issue recurred on June 11, July 8 and July 9 lasting between 1 and 10 hours in each instance. The last incident was resolved on July 9 at approximately 10:45 PM ET.

Users experienced the following issue on the dates mentioned above:  

  • Could not search candidates and/or saw this error “candidate counts and some search/tagging features are temporarily unavailable. Try again in a few minutes” 

We resolved the search issues described above through the following fixes: 

  • Fixed a defect that resulted in large numbers of unnecessary queries 

  • Optimized search query performance 

  • Separating search queries and removing unnecessary re-querying of data 

  • Removing unnecessary data from search results 

  • Optimized search indexing performance 

  • Performing indexing in bulk 

In order to mitigate recurrence of the future we deployed the fixes described above in addition to establishing enhanced monitoring to proactively address these issues should they arise again in the future.

Posted Jul 25, 2024 - 14:28 PDT

Resolved
Starting on June 10 at 12:30 PM ET users began experiencing intermittent issues with users not being able to search. This issue recurred on June 11, July 8 and July 9 lasting between 1 and 10 hours in each instance. This issue is now fully resolved.

There should be no further impact at this time, but please reach out to our support team if any additional assistance is required.
Posted Jul 25, 2024 - 14:10 PDT
Monitoring
A fix has been implemented for the issue causing the candidate search functionality. Customers should now be able to search candidates and utilize Lever as normal. We’re currently monitoring to ensure that there are no further issues, and we’ll send a final update to confirm that there have been no recurrences.
Posted Jul 09, 2024 - 08:44 PDT
Investigating
We are continuing to investigate the issue where users are experiencing errors when viewing the candidates page. Users may intermittently see an error stating "Candidate counts and some search/tagging features are temporarily unavailable. Try again in a few minutes." Our engineers are actively working on a fix. We will continue to update the status page as we continue to investigate.
Posted Jul 09, 2024 - 08:01 PDT
Monitoring
Our engineering teams have identified the issue and have taken steps to relieve the immediate issue. Our team is actively monitoring while we continue to investigate root cause and deploy additional long term fixes to help mitigate recurrence of the issue.
Posted Jul 08, 2024 - 13:15 PDT
Update
We are continuing to investigate the issue where users are experiencing errors when viewing the candidates page. Users may intermittently see an error stating "Candidate counts and some search/tagging features are temporarily unavailable. Try again in a few minutes." Our engineers are actively working on a fix. We will continue to update the status page as we continue to investigate.
Posted Jul 08, 2024 - 10:53 PDT
Investigating
We are currently investigating an issue that is intermittently affecting the candidate search functionality, and delayed loading within Lever. Users may intermittently experience candidate search related issues and see the error message "Candidate counts and some search/tagging features are temporarily unavailable. Try again in a few minutes." Our Engineering teams are actively working to resolve this as soon as possible.
Posted Jul 01, 2024 - 12:12 PDT
Monitoring
A fix has been implemented for the issue causing the candidate search functionality. Customers should now be able to search candidates and utilize Lever as normal. We’re currently monitoring to ensure that there are no further issues, and we’ll send a final update to confirm that there have been no recurrences.
Posted Jun 11, 2024 - 10:26 PDT
Investigating
We are currently investigating an issue that is intermittently affecting the candidate search functionality. Users may intermittently experience candidate search related issues and see the error message "Candidate counts and some search/tagging features are temporarily unavailable. Try again in a few minutes." Our Engineering teams are actively working to resolve this as soon as possible.
Posted Jun 11, 2024 - 08:39 PDT
This incident affected: Global Data Center - LeverTRM (Hire).