Degraded email services
Incident Report for Lever
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 28, 2019 - 16:23 PDT
Identified
We have identified an issue that is currently impacting the ability to send emails. We are working on a fix.
Posted 6 months ago. Apr 28, 2019 - 14:46 PDT
This incident affected: hire.