This incident has been resolved. Impact Summary: Users may have experienced delays in getting up-to-date reporting data, specifically related to profile cards. Incident Duration: Started at approximately 4 am EST and resolution confirmed at 9 am EST
An RCA will be provided within 7-10 business days
Posted Mar 26, 2026 - 11:13 PDT
Update
We are continuing to monitor for any further issues.
Posted Mar 26, 2026 - 07:13 PDT
Monitoring
Mitigation steps have been applied and service functionality is returning to normal and processing of delayed data should be complete within the next 2 hours. We are monitoring for continued performance and stability. Next update: 12 pm EST or upon full resolution.
Posted Mar 26, 2026 - 07:12 PDT
Identified
We have identified the root cause affecting the delay of data related top profile cards. Mitigation is currently in progress.
Next update: 10:30 am EST or sooner.
Posted Mar 26, 2026 - 05:36 PDT
Investigating
We are investigating an issue affecting the availability of reporting data. Users may experience delays in getting up-to-date reporting data, specifically related to profile cards.
Start time: Approximately 4 am EST Next update: 10 am EST or sooner.
Posted Mar 26, 2026 - 05:02 PDT
This incident affected: Global Data Center - LeverTRM (Visual Insights).