Lever Hire outage
Incident Report for Lever
Resolved
This incident has been resolved. Please reach out to our Support team if you continue to experience issues.
Posted Sep 01, 2020 - 13:38 PDT
Monitoring
We have restored access to Lever Hire and are monitoring the fix.
Posted Sep 01, 2020 - 13:18 PDT
Identified
The issue has been identified and we are working to put a fix in place.
Posted Sep 01, 2020 - 12:35 PDT
Update
We are still working on restoring access to Lever Hire. Lever Jobs is operational.
Posted Sep 01, 2020 - 11:38 PDT
Investigating
We are currently investigating an issue loading Lever Hire and Jobs.
Posted Sep 01, 2020 - 11:19 PDT
This incident affected: EU Data Center - LeverTRM (Hire).