Issue saving job postings
Incident Report for Lever
Resolved
This incident has been resolved
Posted Jan 22, 2020 - 11:39 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 22, 2020 - 09:35 PST
Update
We are continuing to investigate this issue.
Posted Jan 22, 2020 - 09:20 PST
Investigating
We are currently investigating an issue that is preventing users from saving job postings.
Posted Jan 22, 2020 - 09:20 PST
This incident affected: Global Data Center - LeverTRM (Career Site).