Intermittent 500 Internal Server Errors
Incident Report for Lever
Resolved
Some customers may have experienced trouble connecting to Lever today. We have identified the root cause and successfully resolved this issue. Thank you for your patience!
Posted over 1 year ago. Nov 28, 2017 - 08:50 PST
Investigating
Some customers using Lever's application are experiencing downtime. We are aware of the issue and are working toward a resolution.
Posted over 1 year ago. Nov 28, 2017 - 08:10 PST