Scheduling Outage for some Microsoft Office 365 Accounts - Investigating

Incident Report for Lever

Resolved

This incident has been resolved.

Incident Duration: April 21, 2026, 1:40 PM– April 23, 2026 11:00 AM PT
Impact Summary: During this window, customers using Microsoft Office365 were unable to retrieve interviewer availability or schedule interviews. Existing data was not lost, but new scheduling actions failed until service was restored.
Cause: An internal encryption key rotation was completed for several services, but a related dependency used by the calendar service was not updated. As a result, the calendar service was unable to read newly issued Microsoft access tokens, causing scheduling requests to fail for Office365-connected accounts.
Mitigation: The calendar service was updated to use the correct dependency compatible with the new encryption keys. Once deployed, scheduling functionality was fully restored and verified in production.

An RCA will be provided within 7-10 business days if applicable.
Posted Apr 23, 2026 - 13:11 PDT

Investigating

We are investigating an issue affecting some users Microsoft Office 365 email/calendar services are unable to schedule interview events or send emails in Lever.

The impact appears to be limited to only accounts where Administrator Consent for email/calendar permissions is enabled.

Affected users are currently unable to schedule interviews or send emails in Lever and may see one or more error messages including “Could not load events” and/or “Your email/calendar integration isn't working” related to scheduling and email.

We are currently investigating this issue and will provide updates from our Engineering team as new information becomes available.

Users may experience issues when scheduling interviews or sending emails.
Start time: April 21, 2026, 1:40 PM PDT
Posted Apr 23, 2026 - 11:26 PDT
This incident affected: Third-Party Workflow Dependencies (Microsoft Office 365 Email/Calendar Integration).