Replies to support@lever.co are not being deliverd
Incident Report for Lever
Resolved
The issue where customers were not able to reply to support tickets has been resolved. The incident occurred approximately from 5/21/23 @ 5:30pm PT to 5/22 5am PT. There should be no further impact at this time and users will be able to reply to support tickets, but please reach out via chat to us at Support, if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new
Posted May 22, 2023 - 09:00 PDT
Investigating
We are investigating an issue impacting Lever support, where replies to Lever support are not being delivered. We became aware of this issue at around 5:30 PM PT. Users will receive an error message when replying to Lever support showing "Address not found" and replies will not send. In the meantime, users could chat into Lever support to receive further assistance. We will provide an update as soon as we have additional information about this matter.
Posted May 21, 2023 - 20:28 PDT
This incident affected: Lever.co (Contact Support).