Some users receiving 500 errors
Incident Report for Lever
Resolved
The issue causing some customers to receive 500 errors has been resolved. There should be no further impact at this time, but please reach out to us at Support if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new
Posted Nov 11, 2020 - 11:29 PST
Investigating
We are currently investigating some user reports of 500 errors when accessing Lever. We became aware of this issue at 10:25 AM PST. We’re working to identify the issue and put a resolution in place as soon as possible.
Posted Nov 11, 2020 - 10:49 PST
This incident affected: hire.