500 Error when accessing Lever platform
Incident Report for Lever
Resolved
The issue where 500 errors were being encountered when attempting to access hire.lever.co has been resolved. There should be no further impact at this time, but please reach out to us at Support if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new
Posted Feb 18, 2025 - 13:09 PST
Monitoring
A fix has been implemented for the issue causing the '500 error' messages. Customers should now be able to access hire.lever.co once more. We’re currently monitoring to ensure that there are no further issues, and we’ll send a final update to confirm that there have been no recurrences.
Posted Feb 18, 2025 - 10:14 PST
Update
Our team is still actively working to restore functionality to the Lever tool. We will continue to provide updates as they are made available.
Posted Feb 18, 2025 - 09:03 PST
Identified
We have identified an issue where the 500 Error is received when accessing Lever, affecting most North America customers. We became aware of this issue at 9am EST. We will keep you updated as we continue working on this issue and await further information from our engineering teams.
Posted Feb 18, 2025 - 07:12 PST
This incident affected: Global Data Center - LeverTRM (Hire).