Google Cloud Services Down - Pillar Impacted

Incident Report for Lever

Postmortem

On June 12, 2025, between 10:51 AM and 1:36 PM PT, Pillar experienced a service outage due to a widespread disruption within Google Cloud Platform (GCP), our cloud infrastructure provider. During this time, customers were unable to access the Pillar web application (app.pillar.hr), and Pillar integrations within Jobvite and Lever were also unavailable. The issue was caused by a global outage affecting GCP services, which directly impacted the infrastructure Pillar relies on to remain accessible.

While our team closely monitored the situation, resolution was dependent on GCP restoring its services. Once the platform-wide issue was resolved, Pillar services recovered automatically. Our team also proactively reviewed the impacted period and worked to recover and restore any affected interviews where possible. However, due to the nature of the outage, we were unable to capture data from some interviews that were scheduled during the downtime.

To improve our response to future incidents, we are integrating Pillar monitoring and alerting into Employ’s centralized Incident Response system and evaluating additional strategies to improve platform resilience. Moving forward, customers can view live system availability and updates anytime at https://status.pillar.hr/. We sincerely apologize for the disruption and appreciate your continued trust in us. If you have any questions, please don’t hesitate to reach out.

Posted Jun 19, 2025 - 06:47 PDT

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 03:49 PDT

Identified

An issue has been identified where there appears to be an outage with Google Cloud Services, Pillar is impacted.

https://status.cloud.google.com
Posted Jun 12, 2025 - 11:45 PDT