Lever homepage is down - https://www.lever.co
Incident Report for Lever
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 11, 2019 - 13:10 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Apr 11, 2019 - 11:05 PDT
Investigating
We are currently investigating the issue.
Posted 4 months ago. Apr 11, 2019 - 10:35 PDT