Microsoft 365 service Issues
Incident Report for Lever
Resolved
The issues impacting Microsoft 365 have been resolved.
Posted 6 months ago. May 02, 2019 - 15:43 PDT
Monitoring
Microsoft 365 is currently experiencing an outage. Due to Microsoft's services being unavailable, customers utilizing Lever's O365 integration may experience degraded services. Please visit Microsoft's status page for the most up-to-date information: https://status.office365.com/
Posted 6 months ago. May 02, 2019 - 14:55 PDT
This incident affected: hire.