Lever domain "lever-analytics.com" issues
Incident Report for Lever
Resolved
This issue has been resolved. The domain lever-analytics.com is active again, and links included in Lever communications should work as expected. If any additional assistance is needed, please contact our Support team at https://help.lever.co/hc/en-us/requests/new.
Posted Sep 19, 2023 - 07:15 PDT
Monitoring
A fix has been implemented, and links that are part of Lever messaging should start working as expected, instead of redirecting users to a namecheap landing page.

We are currently monitoring for recurrences. A final notification will be sent out when the issue is considered to be fully resolved.
Posted Sep 18, 2023 - 10:22 PDT
Investigating
We're currently investigating an issue with our domain registrar namecheap, related to lever-analytics.com. Links included in Lever messaging are routed through lever-analytics.com for tracking purposes. It is possible that users are redirected to a namecheap landing page, instead of seeing the expected Lever page.

Additional updates will be provided as soon as a resolution is in place.
Posted Sep 18, 2023 - 08:46 PDT
This incident affected: Global Data Center - LeverTRM (Hire).