Unable to view interviewer names in scheduling window
Incident Report for Lever
Resolved
This incident has been resolved
Posted Jan 29, 2020 - 09:23 PST
Identified
The issue has been identified and a fix is being implemented
Posted Jan 29, 2020 - 08:33 PST
Investigating
We are currently investigating an issue where interviewers' names may not appear next to their scheduled time slot in the scheduling window
Posted Jan 29, 2020 - 08:14 PST
This incident affected: hire.