Ticketing system delays
Incident Report for Lever
Resolved
The issue affecting our ticketing system has been resolved, so support responses should no longer be more delayed than usual.
Posted Oct 14, 2021 - 15:43 PDT
Investigating
We're investigating an issue with our ticketing system that's causing some slowness. This may result in support responses that are more delayed than usual. We apologize for the inconvenience and will post another update here once this issue is resolved.
Posted Oct 13, 2021 - 09:12 PDT
This incident affected: Lever.co (Contact Support).