API key generation issues in EU data center

Incident Report for Lever

Resolved

This incident has been resolved.

Impact Summary:
Customers may have had an issue preventing new API keys from being generated in our EU environment (EUDC).
Existing or pre-existing API connections in the EU region may also be impacted. Global (non-EU) environments were unaffected

An RCA will be provided within 7-10 business days if applicable.
Posted Apr 17, 2026 - 11:53 PDT

Investigating

We are currently investigating an issue preventing new API keys from being generated in our EU environment (EUDC).

Impact:
Existing or pre-existing API connections in the EU region may also be impacted.
Global (non-EU) environments remain unaffected at this time.

Updates to follow shortly
Posted Apr 17, 2026 - 10:45 PDT
This incident affected: EU Data Center - LeverTRM (Integration API & Webhooks).