Slow load times across Lever
Incident Report for Lever
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 26, 2019 - 19:41 PDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Jul 26, 2019 - 19:40 PDT
Update
Load times have returned to normal, and we're continuing to monitor the situation for any residual impact.
Posted 3 months ago. Jul 26, 2019 - 19:39 PDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Jul 26, 2019 - 19:37 PDT
Investigating
We are currently investigating reports of slowness across the Lever application. We'll be providing additional updates as we make progress on our investigation.
Posted 3 months ago. Jul 26, 2019 - 19:18 PDT
This incident affected: hire, interviewer, and reports.