Slowness and inconsistencies loading data on candidate profiles
Incident Report for Lever
Resolved
This incident has been resolved. Please reach out to our Support team if you continue to experience issues.
Posted Sep 01, 2020 - 15:00 PDT
Investigating
We are currently investigating an issue that is causing slowness and inconsistencies loading data on candidate profiles. Affected users may experience slow loading, missing contact data, or issues switching between opportunities. We’re working to identify the issue and put a resolution in place as soon as possible.

In the meantime, users may be able to resolve the issue by refreshing the page, updating to the most recent version of Chrome, and clearing their cache/cookies following the instructions here: https://support.google.com/accounts/answer/32050?co=GENIE.Platform%3DDesktop&hl=en
Posted Sep 01, 2020 - 07:17 PDT
This incident affected: EU Data Center - LeverTRM (Hire).