Issue Loading Lever (EU)
Incident Report for Lever
Resolved
The issue where users saw issues with postings and Candidate profiles that was affecting customers in the EU has been resolved. The incident occurred from 3/28/2023 @11:30pm PT to 3am PT 3/29. Users should refresh Lever to see this fix. There should be no further impact at this time, but please reach out to us at Support if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new
Posted Mar 29, 2023 - 03:01 PDT
Investigating
We’re investigating an issue causing delays when loading (EU instances) Lever and making in-app changes, and we’re working to implement a fix. Additional updates will be provided as soon as a resolution is in place.
Posted Mar 29, 2023 - 01:06 PDT
This incident affected: Global Data Center - LeverTRM (Hire).