Intermittent slowness within Lever
Incident Report for Lever
Resolved
We have made improvements to overall Lever performance, including reducing candidate page load times by 25%. We have also improved monitoring and incident response times related to these behaviors. We will continue to monitor and improve system performance. If you experience slowness within Lever, please reach out to Support by creating a ticket at: https://help.lever.co/hc/en-us/requests/new
Posted Nov 13, 2020 - 13:08 PST
Monitoring
We have made some improvements to address the issues causing intermittent slowness in Lever. We’re currently monitoring to ensure that there are no further issues, and we’ll send a final update to confirm that there have been no recurrences. If you are still experiencing issues with slowness, please submit a ticket to our support team here: https://help.lever.co/hc/en-us/requests/new
Posted Oct 06, 2020 - 11:14 PDT
Investigating
We are currently investigating where users may experience slowness within Lever. We became aware of this issue around Septemeber 10th and affected users will experience data loading slower than usual. We’re working to identify the issue and put a resolution in place as soon as possible.
Posted Sep 16, 2020 - 10:26 PDT
This incident affected: EU Data Center - LeverTRM (Hire).