The issue with interactions on candidate profiles has been resolved, and we have not seen any additional occurrences of this behavior. The incident occurred from approximately 1:30 am Pacific time until approximately 3:30 am Pacific time on 6/17/2025. There should be no further impact at this time, but please reach out to us at Support if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new
Posted Jun 17, 2025 - 11:27 PDT
Monitoring
A fix has been implemented for the issue causing latency/interactivity issues on the candidate profiles. Customers should now be able to properly access candidate profiles and navigate the pages. We’re currently monitoring to ensure that there are no further issues, and we’ll send a final update to confirm that there have been no recurrences.
Posted Jun 17, 2025 - 04:02 PDT
Investigating
We are currently investigating an issue that is intermittently affecting the navigation of the Lever webpage. Issues impacting candidate profiles were noticed around 2 am Pacific Time. Users may intermittently experience delays/non-responsiveness when navigating through candidate profiles and attempting specific actions. Our Engineering teams are actively working to resolve this as soon as possible.
Posted Jun 17, 2025 - 02:21 PDT
This incident affected: Global Data Center - LeverTRM (Hire).