Automation Workflows Not Triggering

Incident Report for Lever

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 08:04 PST

Monitoring

This issue has been resolved and our teams are monitoring to ensure continued stability
Posted Jan 22, 2026 - 05:14 PST

Update

We are continuing to investigate this issue.
Posted Jan 21, 2026 - 17:57 PST

Update

We are continuing to investigate this issue. We have found that automation workflows are still processing with a delay. New information will be shared as soon as possible.
Posted Jan 21, 2026 - 17:55 PST

Investigating

We became aware of an issue where automation workflows are not triggering starting around 1/21/2026 at 9:40am PT. We are currently investigating and will provide an update as soon as possible.
Posted Jan 21, 2026 - 14:08 PST
This incident affected: Global Data Center - LeverTRM (Hire).