Internal server 500 errors
Incident Report for Lever
Resolved
This incident is resolved. Please submit a support ticket if you continue to experience issues.
Posted May 21, 2020 - 19:50 PDT
Monitoring
We've identified the issue and are monitoring for additional errors.
Posted May 21, 2020 - 17:56 PDT
Investigating
We are investigating an issue that's causing internal server errors.
Posted May 21, 2020 - 17:40 PDT
This incident affected: EU Data Center - LeverTRM (Hire).