Candidate Messaging Delayed
Incident Report for Lever
Resolved
The candidate messaging delay issue has now been resolved. The incident started at 7:00 PM EST and ended as of 9:45 PM EST. There should be no further impact at this time.
Posted Jun 04, 2024 - 19:43 PDT
Monitoring
We have identified an issue resulting in a significant delay of text messages to candidates. We’re currently monitoring to ensure that there are no further issues, and we’ll send a final update to confirm that there have been no recurrences.
Posted Jun 04, 2024 - 18:59 PDT
This incident affected: Global Data Center - LeverTRM (Hire).