Scheduling Outage for some Microsoft Office 365 Accounts

Incident Report for Lever

Postmortem

We want to share an update on a recent automation issue, including what happened, how it was resolved, and the steps we’ve taken to prevent it from happening again.

Date/Time: April 21, 2026, 1:40 PM – 4:39 PM PDT
Duration: 2 hours 59 minutes

Customer Impact

During this window, customers using Microsoft Office365 were unable to retrieve interviewer availability or schedule interviews. Existing data was not lost, but new scheduling actions failed until service was restored.

Root Cause

An internal encryption key rotation was completed for several services, but a related dependency used by the calendar service was not updated. As a result, the calendar service was unable to read newly issued Microsoft access tokens, causing scheduling requests to fail for Office365-connected accounts.

Resolution

The calendar service was updated to use the correct dependency compatible with the new encryption keys. Once deployed, scheduling functionality was fully restored and verified in production.

Preventative Actions

  • Expand automated test coverage to explicitly validate scheduling flows for Microsoft Office365 accounts.
  • Improve internal validation and service dependency checks during encryption key rotations.
Posted Apr 23, 2026 - 06:34 PDT

Resolved

This incident has been resolved.

Issue: Users with Microsoft 365 calendar integrations experienced authentication failures, causing email and calendar sync to stop working. Resetting the calendar cache resulted in an endless loading state.

Impact: Affected users were unable to schedule interviews or view availability in Lever. The issue was limited to accounts using Admin Consent–based Microsoft 365 authentication.

A fix was applied at approximately 4:39 pm PDT on 4/24/2026.
An RCA will be available within 7-10 business days if applicable.
Posted Apr 22, 2026 - 05:07 PDT

Monitoring

We have identified the issue causing failed Lever user permission syncs with Microsoft Office 365 email/calendar services for users with Administrator provided email/calendar permissions. A fix was deployed at approx. 4:39pm PT on 4/21/2026.

We are actively monitoring the fix to ensure continued email/calendar sync availability.
Posted Apr 21, 2026 - 16:39 PDT

Update

We are continuing to investigate this issue.
Posted Apr 21, 2026 - 16:26 PDT

Investigating

Around 8:50am PT on 4/21/2026 we became aware of an issue where some users Microsoft Office 365 email/calendar services are unable to schedule interview events or send emails in Lever.

The impact appears to be limited to only accounts where Administrator Consent for email/calendar permissions is enabled.

Affected users are currently unable to schedule interviews or send emails in Lever and may see one or more error messages including “Could not load events” and/or “Your email/calendar integration isn't working” related to scheduling and email.

We are currently investigating this issue and will provide updates from our Engineering team as new information becomes available.
Posted Apr 21, 2026 - 08:50 PDT
This incident affected: Third-Party Workflow Dependencies (Microsoft Office 365 Email/Calendar Integration).