Intermittent issues impacting Lever Hire
Incident Report for Lever
Resolved
The issue where candidates have received incorrect message when they signed their offer has been resolved. There should be no further impact at this time, but please reach out to us at Support if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new
Posted Jul 22, 2021 - 15:37 PDT
Investigating
We are currently investigating an issue that is affecting the offer process. Candidates that have signed offers will see an incorrect message showing "You declined the offer." Our Engineering teams are actively working to resolve this as soon as possible.
Posted Jul 22, 2021 - 15:20 PDT
This incident affected: Global Data Center - LeverTRM (Hire).