Checkr integration not triggering background checks
Incident Report for Lever
Resolved
This issue has been resolved. If you continue to experience any issues with Checkr background checks, please contact our support team.
Posted Mar 13, 2020 - 12:48 PDT
Investigating
We are currently investigating an issue where background checks are not being triggered in Checkr, for candidates moved into the trigger stage in Lever.
Posted Mar 10, 2020 - 09:48 PDT
This incident affected: hire.