Users unable to access Lever
Incident Report for Lever
Postmortem

Our teams were alerted to an outage impacting users ability to access Lever at approximately on July 19 at 9:45 PM PT and ended at 10:30 PM PT. 

Our team quickly identified an issue related to an expired domain resulting in users unable to access the site. We were able to re-enable the domain resolving the issue.

In order to mitigate future recurrence of the issue we reviewed all our domains/sub-domains to ensure they are set to an auto-renew policy to avoid recurrence of the issue.

Posted Jul 31, 2024 - 11:10 PDT

Resolved
The issue where users were not able to access Lever has been resolved. The incident occurred from 9:45 PM until 10:30 PM PT. There should be no further impact at this time, but please reach out to our Support team should any additional assistance be required.
Posted Jul 19, 2024 - 22:32 PDT
Identified
We are currently investigating an issue that is impacting all users ability to access lever. Issues impacting Lever were noticed around 9:45 PM PT. Our Engineering teams are actively working to resolve this as soon as possible.
Posted Jul 19, 2024 - 21:55 PDT
This incident affected: Global Data Center - LeverTRM (Career Site, Visual Insights, Integration API & Webhooks, Hire).