"This link seems to be out of date" error preventing candidates from signing offers
Incident Report for Lever
Resolved
The issue where offers were sent but viewing the sent document link showed a "This link seems to be out of date” error has been resolved. This issue impacted the global data center from yesterday at 5:19 PM to today at 6:28 AM PDT and the EU data center from yesterday at 10 PM to today at 6:36 AM PDT. Users should now be able to send offer letters without issues. There should be no further impact at this time, but please reach out to us at Support if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new
Posted Jul 15, 2021 - 07:09 PDT
Identified
We’ve identified the issue causing users to be unable to properly send offer letters, and we’re working to implement a fix. Any offers that must be sent immediately should be sent outside of Lever. Additional updates will be provided as soon as a resolution is in place.
Posted Jul 15, 2021 - 00:57 PDT
This incident affected: EU Data Center - LeverTRM (Hire) and Global Data Center - LeverTRM (Hire).