Resumes and Offers showing an abbreviated display when viewing, download operational
Incident Report for Lever
Resolved
This incident has been resolved.
Posted Oct 27, 2022 - 12:36 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 27, 2022 - 06:50 PDT
Investigating
We are currently investigating this issue.
Posted Oct 27, 2022 - 06:26 PDT
This incident affected: Global Data Center - LeverTRM (Hire).