Seek Integration delay in processing candidates
Incident Report for Lever
Resolved
We've confirmed that the incident has been fully resolved.
Posted Feb 19, 2020 - 16:58 PST
Monitoring
We have identified and released a fix for this issue, and we are currently monitoring to ensure that the issue has been resolved.
Posted Feb 19, 2020 - 15:45 PST
Investigating
We are currently experiencing a delay in pushing candidate applications to Lever via the Seek integration. We have identified the issue, and are working to resolve. Updates will be provided as they are available.
Posted Feb 18, 2020 - 06:43 PST
This incident affected: Global Data Center - LeverTRM (Career Site) and EU Data Center - LeverTRM (Hire).