Delayed notification delivery
Incident Report for Lever
Resolved
This incident has been resolved. We've released a fix and all delayed notifications have been delivered.
Posted 7 months ago. Feb 05, 2019 - 12:53 PST
Identified
Notifications to users (Lever inbox and email notifications) are currently delayed. We've identified the cause and our engineers are actively working on a fix.
Posted 7 months ago. Feb 05, 2019 - 11:59 PST
This incident affected: hire.