Intermittent Scheduling Errors
Incident Report for Lever
Resolved
We have identified the issue and confirmed the issue is resolved and no longer impacting customers.
Posted 8 months ago. Feb 22, 2019 - 13:45 PST
Update
We are continuing to monitor for any further issues.
Posted 8 months ago. Feb 22, 2019 - 13:38 PST
Monitoring
Some customers may have experienced trouble using Lever's calendaring functionality between Wednesday 2/20 and Thursday 2/21. We have identified and addressed the root cause. If you are still experiencing any issues related to scheduling or permissions, please contact us at support@lever.co.
Posted 8 months ago. Feb 22, 2019 - 13:34 PST
This incident affected: hire.