General opportunity created when archiving an opportunity
Incident Report for Lever
Resolved
This issue has been resolved.
Posted Apr 01, 2020 - 07:44 PDT
Investigating
We are currently investigating an issue that is creating a general opportunity when archiving an opportunity. We will provide updates as soon as possible.
Posted Apr 01, 2020 - 03:59 PDT
This incident affected: EU Data Center - LeverTRM (Hire).