Microsoft 365
Incident Report for Lever
Resolved
Microsoft has confirmed that this incident has been resolved.
Posted Nov 19, 2019 - 21:41 PST
Monitoring
Microsoft has identified that multiple Microsoft 365 services are affected by a current incident, that may result in degradation of usage for Lever customers using Microsoft 365. Microsoft is actively looking for the swiftest means of restoring access. Please refer to http://status.office.com for details.
Posted Nov 19, 2019 - 18:38 PST
This incident affected: EU Data Center - LeverTRM (Hire).